n-wp.ru — блог о WordPress

Проблема плагин NextGEN Gallery до последнего времени работал…

Проблема плагин NextGEN Gallery до последнего времени работал отлично, но вот в один прекрасный день отказал пакетный загрузчик, через обычный все грузится по одной, через флешевый либо ошибка 2038 либо 302, перенес весь сайт на локалхост, на денвере все работает,гуглил нашел такое решение нужно дбавить в .htaccess такие строки
SecFilterEngine Off
SecFilterScanPOST Off тоже не помогает, но самое поразительное что в ie все работает, а opera и mozila не в какую
все права на папках 777, размер файлов тоже не большой
проблем не должен вызывать, да и стандартная загрузка работает, на конфликт плагинов тоже не
похоже, (все отключал). Вообщем я пас что это за
неуловимый баг не знаю и прошу помощи

6 комментариев

  • в один прекрасный день отказал пакетный загрузчик

    Такого не бывает. Либо вы что-то сделали (установили плагин или скрипт, конфликтующий с флеш-загрузчиком), либо ваш хостер что-то сделал с сервером (например, ограничил выполнение каких-то скриптов).
    Первое, что я бы сделал — отключил все плагины и на дефолтной теме проверил, работает ли флешь-загрузчик.
    Если работает — сменил бы тему на вашу и посмотрел. Если перестал работать — ищите внедренные в functions.php скрипты, конфликтующие с движком.
    Если работает, то включал бы по-одному плагины и смотрел, что происходит.
    Таким образом можно найти любую ошибку.
    Если же даже на дефолтной теме без плагинов флеш-загрузчик не работает — нужно обращаться к хостеру — он что-то нахимичил.
    Да, и еще — права на всех файлах 777 — это небезопасно. Установите нормальные, безопасные права на папки и файлы. Подробно этот вопрос обсуждался тут: http://n-wp.ru/6698
    И еще: ошибка 2038 явно говорит, что где-то неправильно выставлены права доступа. В файл .htaccess нужно добавить следующее:

    Но вообще эта ситуация ненормальная, и я бы подумал о смене хостера.

  • это то я как раз и делал плагины отключал все и тему дефолтную ставил в .htaccess SecFilterEngine Off SecFilterScanPOST Off добавлял и вообще .htaccess удалял, хостер говорит что у них отключен mod_security, да и хостер вроде не плохой Fastvps) Я бы уже давно сменил хостера но настораживает тот факт что на internet Explorer все работает правильно и стандартный wp флеш загрузчик работает хорошо, это моему пониманию не подвластно на сколько я знаю сервер не различает версии браузера

  • то есть что такое AdBlock ? хотя не думаю переносил сайт на денвер на нем работало со всех браузеров, какая несовместимость плагина с хостингом которая неожиданно появилась сама собой) я бы сменил давно хостера но с fast уже давно работаю привык к ткхподежке да и где мне ещё дадут 10гб диска (под фотки) и достаточно оперативки под wp за 3,5 евро в месяц