n-wp.ru — блог о WordPress

Как пользователям IE 6 показывать классическую тему оформления блога | Serve Default to IE6

Плагин, позволяющий загружать только классическую или дефолтную тему WordPress, если посетитель использует устаревший браузер Internet Explorer 6.

К сожалению, инертность мышления не дает многим сменить браузер Internet Еxplorer 6 на более новую версию, причем иногда это не просто прихоть пользователей, а корпоративные требования. Поэтому многие блоги выглядят ужасно — используемые в них темы не предназначены для отображения в устаревших браузерах, которые не поддерживают многие современные стандарты. К таковым прежде всего относится Internet Explorer 6 (и более ранней версии), в котором большинство модных сайтов выглядит некорректно. Перед загрузкой блога пользователя IE6 можно предупредить, что сайт будет выглядеть не так, как в более новых браузерах, могут возникнутьошибки, а иногда и вовсе сайт не будет отображаться — для этого достаточно воспользоваться красивым плагином WP-NoIE6. Можно попробовать сделать заплатки, которые бы корректировали отображение блога именно в этом браузере, но это утомительная задача. Есть еще один выход — показывать блог, используя дефолтную или классическую тему, которые, как известно, корректно отображаются в Internet Explorer 6.

Для этого нужно создать проверку браузера, которым посетитель открывает блог, и если проверка выявила, что он использует Internet Explorer, принудительно загружать блог, используя дефолтную тему. Делается это с помощью простого плагина Serve Default to IE6.

Если вы хотите, чтобы загружалась не дефолтная тема, а классическая, то откройте файл плагина и измените строку

на

Скачать
Serve Default to IE6
вы перейдете по ссылке http://www.nathanrice.net/blog/serve-ie6-visitors-the-default-wordpress-theme/

tiaurus

Являюсь создателем n-wp.ru — блога о WordPress для новичков. Мне интересно многое, поэтому еще я сделал 123-box.ru — блог о программах для Windows, и tiaurus.info — блог о красоте.

1 комментарий

  • 1) скачать его нельзя, ссылка битая. Но можно зайти на страницу http://www.nathanrice.net/blog/serve-ie6-visitors-the-default-wordpress-theme/
    и самому его создать. Там есть текст плагина.
    В название темы можно вписать любую тему что у вас стоит. Я вписал twentyten и нормально работал.

    Однако, вылезла проблема. На одном из блогов, где я хотел его использовать, я использую плагин для кеша Maxsite MAXCACHE. И оказалось что работа двух этих плагинов вместе невозможно.

    Нет, они ничего не рушат, просто получается ерунда полная… :( А жаль…