n-wp.ru — блог о WordPress

Проблема с plugin.php в строке 227

На трех сайтах у одного хостера стали появляться проблемы с plugin.php в строке 227.
Warning: Parameter 1 to ace_where() expected to be a reference, value given in /home/f/footbru/htdocs/wp-includes/plugin.php on line 227 Warning: Parameter 1 to ace_join() expected to be a reference, value given in /home/__/______/htdocs/wp-includes/plugin.php on line 227

Что это и как с этим бороться?

5 комментариев

  • Покажусь кэпом, но дело в хостинге, возможно не поддерживает WP.. все таки это системный фаил, а не добавленный Вами. Попробуйте официальный релиз, а не сборку. Если у хостинга есть предустановленные скрипты, поищите там WordPress и установите его так.
    Если Вы заметили ошибку при обновлению на последнию версию WP, то дело в PHP и MySQL. У хостера возможно старая версия чего-то. Всё равно, всё это сведется к написанию письма в суппорт, так что сделайте это прежде всего.

    • гы, уж точно дело не в хостинге.
      Все дело в кривизне рук и лени вебмастера.
      Решение:
      1. Выпрямляете руки и приклеиваете в нужное место.
      2. Заходите в админку, раздел плагины. Отключаете плагин смотрите сайт, ошибка осталось, включаете плагин и так с каждым плагином который активирован. До тех пор пока не найдете нужный.
      Нашли? Лезете на сайт разработчика и обновляете его, либо ищите там решение проблемы.

      • кстати забыл написать.
        Чаще всего это надо удалить простой символ &
        т.е. находите модель из-за которого ошибка.
        заходите по фтп в папку шаблона.
        далее ищите файл с функцией ace_where , открываете файл, находите строку с этой функцией, рядом по идее будет символ & — удаляете, сохраняете файл. Наслаждаетесь.
        Вся беда в том, что плагин написан для php5.2, а у хостера стоит php5.3 вот и запарка.

  • Лучше поздно чем никогда.
    Наверное на хостинге у вас стоит версия php 5.3 а плагин который вы используете (Advanced Category Excluder) некорректно работает с ней. Автором он не обновлялся больше 2 лет.
    Переходите на http://wordpress.org/extend/plugins/simply-exclude/
    и будет счастье