Как правильно обновлять WordPress

Как правильно обновлять Wordpress | n-wp.ru Настройки

То, о чем так долго все говорили, чего с нетерпением ждали, свершилось — вышел WordPress третьего поколения. Нововведений в нем масса, и вы о них еще узнаете, но перечислю два основных: возможность создания мультиблогового сайта и работа с дополнительными таксономическими терминами. Первое подразумевает, что теперь достаточно одного движка WordPress для ведения нескольких блогов с общим доменным именем. Второе говорит о том, что помимо рубрик и меток можно будет использовать еще и дополнительные определители, которые вы создадите сами.

Чтобы познакомиться с основными возможностями третьей версии, посмотрите демонстрационное видео.

Теперь по поводу обновления. Если вы хотите автоматически обновить WordPress, то я, во избежание ошибок, советую придерживаться такого порядка:

  1. Очистите кэш в настройках кэширующих плагинов
  2. Деактивируйте все плагины (не удалите, а отключите)
  3. Обновите WordPress (Консоль — обновления)
  4. Активируйте плагины один за одним, проверяя их параметры

Эти простые четыре шага помогут не допустить ситуации, когда блог перестает грузиться. Не активируйте плагины все сразу, не торопитесь. Активируя плагины один за одним, вы сможете выявить, какие из них не совместимы с новой версией (у меня, например, DB Cache Reload вызывал ошибку при редактировании нового поста — пришлось отключить).

Если вы вручную обновляете WordPress, просто переписывая новые файлы поверх старых, то придерживайтесь тех же правил.

Как правильно обновлять WordPress

Не забывайте, что наряду с английской версией обычно сразу же появляется и русская.

tiaurus

Автор n-wp.ru — блога о WordPress для новичков.

Оцените автора
Добавить комментарий

  1. Олег

    Что-то боязно!:)а с админке если нажать на авто обновления и перед этим следуя выше правилам на русском встанет??или это отдельно надо скачивать как у тебя на скрине???:)У меня в админе пишет :Доступен WordPress 3.0! Пожалуйста, обновитесь! так можно!!??или английская вылизет версия??

    Ответить
  2. Флетчер

    Что то у меня в сборке от лекактуса не находит русскую версию на сайте лекактуса. Подожду пока с обновлением.

    Ответить
    1. Олег

      Это Лекактус ещё не обновил как выложит так обновись потому что это его перевод:)Жди пока он выложит!!А у меня стандартноя стоит вроде пока касеков не заметил в обновлении!!Обновился!!всё на русском автоматом через админ панель!!

      Ответить
      1. Флетчер

        А ну ясно. Что-то лекактус долго, там вроде не так уж много допереводить то надо. WP 3.0 На Денвере поставил ­- полёт нормальный :)

        Ответить
  3. Олег

    Я бы вобще хотел чтоб чтоб tiaurus сделал мануал по обновлению версии перевода с Лекактуса на стандартную прописка кода и т.п.у кого сайты на его переводе!!Так как Лекактус он же (Иван Калинин)уже писал на своём форуме не однократно что устал и у него депресняк по обновлению и т.п.!!А депресняк потому что конкуренты не дремлют с русского WordPress.ru быстрей его всё делают и продвигать стали!!Это видно по абновлениям версии скорости данного движка на русский!!Мне та серовно я его перевод не использую вот людей жалко!!Процентов наверно 40 русског рунета используют его перевод!!Где соответственно наверно обновления идут через него:)!!

    Ответить
    1. tiaurus

      Если честно, то я давно уже не пользуюсь версиями Лекактуса. И началось все именно после его заявления, что у него депресняк. Я уважаю его работу, мне она кажется крайне полезной и перспективной. Я так же понимаю, что все мы люди, и у каждого — свое настроение, своя мотивация. Однако я не могу себе позволить, чтобы работа моего блога зависела не от меня, а от настроения другого человека. Поэтому я принял трудное для себя решение перейти на официальные релизы. Более того, в половине моих блогов стоит не русская, а оригинальная, анаглийская версия WordPress без всякого перевода. Она работает быстрее из-за болеее низкого потребления оперативной памяти, которая в русской версии расходуется на обработку файла перевода.
      Если честно, я не понял, что вы хотели, чтобы я сделал? Описал процесс замены официальной версии WordPress сборкой Лекактуса? Или наоборот?

      Ответить
    2. Флетчер

      В принципе можно сначала автоматом обновиться на английскую версию WP, а потом просто подключить русский официальный перевод в wp-config =)

      Ответить
    3. Sergey Biryukov

      мануал по обновлению версии перевода с Лекактуса на стандартную

      http://codex.wordpress.org/ЧАВО/Как_обновить_WordPress_Lecactus_Edition

      Ответить
  4. Флетчер

    Только что обновился так как и описал выше. Замерил потребление памяти в админке — с подключенной русской локализацией 17мБ, а чисто английская 13мБ (все плагины отключены).

    Ответить
    1. tiaurus

      Что и требовалось доказать :) .

      Ответить
  5. Олег

    Вот и начались первые проблемки!!:)Проблема с загрузкой через админ панель (установка и обновление плагинов)выдаёт ошибку!!:Не удалось создать директорию. /public_html как чё исправить??деректория вроди имется через фтп глядел !!у меня почемуто папки похожии две одинаковые получились после обновления на 3 версию??:(Но по дате директория староя ещё 2.9.2 походу!!короче чтоб долго не обьяснять как это исправить:(((нет возможности обновить плагины и новые установить?!!tiaurus дружище выручи пожалуйста!!!кеш плагин чистил вроде??у меня стоит Hyper Cache что надо сделать!!???????

    Ответить
    1. Олег, пишите нормально, соблюдая пунктуацию и орфографию. Иначе нихрена не понять, что вы хотите сказать.
      Помогаю:
      0. Очистите кэш в плагинах кэширования.
      1. Деактивируйте все плагины.
      2. Переустановите WordPress (Консоль — обновления — переустановить).
      3. Активируйте плагины один за одним по порядку, наблюдая за поведением блога. Так вы найдете несовместимый плагин.
      Думаю, у вас установлен DB Cache Reload — он не работает с WordPress 3.

      Ответить
      1. Art

        Да как это DB cache reloaded не работает с WP3.0??

        <!-- Generated in 9.492 seconds. Made 38 queries to database and 36 cached queries. Memory used - 12.35MB -->
        

        Вот такое у меня выдаёт в футере.

        Ответить
        1. tiaurus

          А у меня при включенном DBCR админка не грузится. А вот как только удалишь его — все ок. В предыдущей версии этого не было. Разбираться долго не стал, и просто отказался от него.

          Ответить
        2. ur_all

          Тоже столкнулся с этой проблемой, проделал шаги, которые тут советовали — плагины поотключал, права вроде везде выставлены корректно, но упорно выдаёт:

          Ответить
          1. ur_all

            Что-то не дописалось. Словом, упорно выдается, что «не удалось создать директорию public_html». Могли бы помочь за разумную денежку решить проблему? Заранее спасибо!

            Ответить
            1. Напишите мне по электронной почте tiaurus@msn.com — будем посмотреть :)

              Ответить
              1. ur_all

                Написал Вам на указанный е-мейл ещё 10 ноября, но ответа не получал. Моё письмо дошло?

                Ответить
                1. ur_all

                  Продублировал послание.

                  Ответить
  6. Олег

    У меня стоит вот этот плагин advanced-cache.php

    Расширенный плагин кэширования.Он установился автоматом с новой версией!!Так он и есть ?DB Cache Reload или это другое??

    Ответить
    1. tiaurus

      Не путайте два совершенно разных плагина.

      Ответить
  7. Олег

    DB Cache Reload у меня не стоит!!!

    Ответить
    1. tiaurus

      Отлично! Проделайте по шагам то, что я написал выше, и выявите причину нестабильной работы.

      Ответить
  8. Олег

    Шаги не помогают!!:)всё делал по инструкции!!!!!!!!:(короче к мастеру придётся обращаться за $ чтоб наладил!!

    Ответить
  9. Олег

    Я письмо тебе на почту отправил с проблемой!Сюда не стал писать:)

    Ответить
  10. Олегъ

    Кто обновился? Как впечатления от админки? Удобнее/быстрее/функциональнее чем 2.9.2?

    Ответить
  11. Олег

    5++ Только после таких манёвров (самостоятельно когда) кошелёк опустел на 500 рублей!!:)но не пожалел:))пришлось человеку тех.зад.давать чтоб всё поправил,в итоге всё летает загружается,обновляется и удаляется!!Обновляться обязательно!!Потому что плагины очень быстро разрабатывают под 3.0.хочешь не хочешь а надо!!

    Ответить
  12. Shtirlitz

    У меня и толком не обновилось — пришлось вручную делать 3-ю версию, ни переустановить не получается. Выдает 500 ошибку. да и вообще не нравится эта версия, а куда деваться теперь…

    Ответить
    1. Евгений

      Олег, удалось разобраться с проблемой «Не удалось создать директорию. /public_html» ?

      У меня точно тоже самое. Ни одного плагина и ни одной темы не установлено (голый wp), а автоустановка не работает вообще (ни ядра, ни тем, ни плагинов).

      Права на каталоги нормальные. FTP-доступ тоже в wp-config прописал. И всё равно.

      Есть подозрение, что это связано с safe-Mod.

      Буду благодарен за контакты человека, который смог решить эту проблему.

      Ответить
      1. Думаю, проблема не в WordPress, а в вашем хостинге. У меня все сайты работаю на WordPress, и ни на одном не возникло проблемы с автоматическим обновлением.

        Ответить
        1. Евгений

          Это однозначно, что в хостинге дело.

          Только вот в чем именно? Саппорт пока определить не может

          Ответить
          1. tiaurus

            Ошибка 500 — это однозначно проблема в их сервере (он недоступен). Возможно, у них стоят какие-то ограничения на внешние соединения (WordPress сам скачивает нужные файлы с удаленного сервера и распаковывает их у себя). Возмо так же, что права, выставленные на папки, недостаточны для операции автоматического обновления.

            Ответить
  13. Лариса Клепачева

    А у меня вот такой вопрос: файл wp-config.php в ВП 2.9.2 и 3.0.1 слегка отличаются. Эти отличия принципиальные? Можно ли оставить старый wp-config.php? Можно ли в новый wp-config.php вставить строчки изменяющие интервал автосохранения и количество ревизий?
    Если нет, то как бороться с большим количеством ревизий в ВП 3.0.1?

    Ответить
    1. Можно ли в новый wp-config.php вставить строчки изменяющие интервал автосохранения и количество ревизий? — Можно!

      Ответить
  14. Лариса Клепачева

    Спасибо! Одной проблемой меньше

    Ответить
    1. tiaurus

      А что, есть еще проблемы? Воспользуйтесь системой Q&A!

      Ответить
  15. Grawl

    Хотелось бы побольше узнать о таксономии.

    Ответить
  16. Елена

    Здравствуйте!
    Дело в том, что после очередного автоматического обновления версии движка, а точнее после установки версии 4.0, появилось несколько ошибок в админке сайта, а именно при заходе на страницу внешний вид-настройка темы, выдаёт ошибку, а дословно «Страница не работает, сайт пока не может обработать этот запрос», в общем если я хочу сменить тему или подредактировать её, то теперь этого не сделать, да ещё и ошибка в видимой части сайта, появилась странная надпись вместо удалённой страницы, под шапкой, хотя её вообще быть не должно. Пробовала переустановить версию в ручную, но ничего не изменилось. Помогите решить данную проблему! Спасибо!

    Ответить
    1. tiaurus автор

      Вы пробовали вернуть версию WordPress, которая была до этого?

      Ответить